Last-gen bezitters kunnen Fallout 4 niet spelen

Een hele hoop mensen maken zich zorgen over games, omdat sommige titels minder mooi of groots zouden zijn omdat er met de last-gen consoles rekening gehouden zou worden. Nu is er goed nieuws voor de current-gen eigenaars. Fallout 4 komt niet naar de last-gen consoles… jazeker, de game is current-gen only. Dit is bevestigd door een Bethesda medewerker op NEOGaf.

Voor sommige games zijn het kleine verschillen als ene game voor meerdere generaties gemaakt word. Maar bij een game met de grootsheid als een Fallout game is het toch fijn om te weten dat de ontwikkelaar gebruik kan maken van de volledige capaciteiten van de huidige consoles. Zoals op NEOGaf aangegeven werd:”…the stuff we’re doing will never work there (xbox 360, PlayStation 3).”

Wat denken jullie? Had je liever een last-gen versie zien voorbij komen? Of moet een game zoals dit alleen maar genieten van de nieuwste technologie? Laat ons je mening weten in de comments!

Fallout 4 komt niet naar de last-gen consoles